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N OTE: Step-by-step instructions in this paper refer to menus and dialog boxes found in
Microsoft Word version 6 or 7. Controls for Microsoft Word 97 will vary in some cases,
although the basic principles and in most cases the dialog box and command names are the
same.
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Good News/Bad News About Microsoft Word
The good news is that Microsoft Word can be customized into a fine-tuned machine for writing
scripts. The bad news is that accomplishing that customization can devour every discretionary
moment of your life for months or even years; provided of course that you already know how
to program in visual basic.
The good news about the bad news is that Parnassus software has already done this work for
you and makes the resulting customizations available as a commercial product called Script
Werx™.
This paper introduces the basic tools for customizing Microsoft Word and demonstrates how to
use them. It then demonstrates how Script Werx features build on these basic principles to
provide features that go beyond what scriptwriters with a typical working knowledge of
Microsoft Word could accomplish on their own.
Both screenplay and two-column video formats are addressed. The section on styles uses
examples from the Script Werx screenplay format exclusively. The section on Macros and
Templates reviews features offered by both screenplay and two-column formats.

Styles
A style is all formatting that is appropriate for a specific type of paragraph; such as a slug line
(scene heading), action description, character cue or dialogue. Once a style is defined, it can
easily be applied to any paragraph. For working in the screenplay format, a properly defined
set of styles will eliminate most of the formatting drudgery that would otherwise be necessary
while writing the script.

To create a new style
♦ Format a paragraph on which the style will be based
♦ From the Format menu, select Style. A dialog box will open
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Figure 1 Style dialog box
♦ Click on New, a New Style dialog box will open
♦ Type in name for your new style and click on OK to close the New Style dialog box
then click on Apply to close the Style dialog box.

To apply a style
♦ Place your cursor anywhere in an existing paragraph (it does not have to be highlighted)
or press the Return key on your keyboard to create a new paragraph
♦ From the left end of the Formatting toolbar, click on the downward pointing arrow. A
list of all styles available to you will be displayed.

Figure 2 Formatting toolbar
♦ Select the appropriate style
To redefine an existing style
♦ Modify a paragraph to which that style has already been applied
♦ From the left end of the Formatting toolbar, select the name of the style
♦ A dialog box will ask if you want to redefine the style, click on OK
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To move a style to another document, either
♦ Copy and paste a paragraph to which the style has been applied; or...
♦ Use Organizer (from Format menu, select Style)
The definition of a style can also include the style to apply to the following paragraph. This is
very handy when writing in the screenplay format, since this format incorporates several
predictable patterns: the Action style typically follows a slug line and dialogue follows a
character cue.

To Define a Style for the Following Paragraph
♦ From the Format menu, select Style.
♦ Within the Style dialog box, select the style for which you want to define the style to be
automatically applied to the following paragraph
♦ Click the Modify button. A Modify dialog box will open

Figure 3 Modify Style dialog box
♦ In the field labeled Style for Following Paragraph, use the popdown menu to select the
style that should automatically follow the style you are modifying (its name will be
displayed in the Name field of this Modify Style dialog box)
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The styles provided by Script Werx screenplay templates automate the bulk of formatting
required when writing a screenplay: pressing the Return key on your keyboard at the end of a
slug line will create a new paragraph formatted for action description. Pressing Return at the
end of action description creates a new line for writing a character cue. Pressing Return at the
end of a character cue starts a paragraph for dialogue. Choosing what should happen when
pressing Return at the end of a dialogue paragraph creates a dilemma.
The dilemma is that some writers prefer to automatically rock back and forth between character
cue and dialogue, while others prefer going to action description after writing dialogue. Using
a standard version of Microsoft Word, this would require first training the writer to redefine a
style, and would then require the writer to take the several steps needed to redefine the style.
In Script Werx, this option is presented as a clickable option in a Preferences dialog box that
can be selected from the Script Werx menu.

Figure 4 Preferences dialog box for Script Werx screenplay-format templates
In the lower right corner of this dialog box (Figure 4) the choice of following dialogue with
either a character cue or action description can easily be made without having any knowledge
of styles or how styles are defined or modified.
In the lower left corner of the Preferences dialog box (Figure 4) can be seen the control for a
somewhat related feature, Action Tab. By default, pressing the Tab key when using a Script
Werx screenplay template creates a new Action description paragraph. This means that you can
format an entire screenplay using only the Return and Tab keys. Clicking Normal Tab in this
section of the Preferences dialog box returns the Tab key to its normal function.
In either option, holding down the Shift key while pressing Tab cycles through all available
screenplay styles. This lets you use this single key combination to apply any style to a
paragraph. In addition, each style also has its own unique key combination as well as a button
on the Script Werx Shortcuts toolbar. Whether you prefer using the keyboard or the mouse,
Script Werx lets you apply styles the way you prefer.
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Microsoft Word’s Built-In Heading Styles
An outline feature resident within Microsoft Word can be used to easily collapse a script down
to slug lines or to slug lines and action descriptions. These slug lines or action description
paragraphs can then to clicked and dragged to shuffle the order of script elements.
To do this, you must first apply Microsoft Word’s built-in Heading 1 style to slug lines and
apply the Heading 2 style to action description; which is done automatically by Script Werx.

To Shuffle Scenes
♦ On the View menu, select Outline
♦ On the numbered buttons that will appear at the top of the screen, click 1. The script
will collapse down to slug lines only. By clicking and dragging any of these slug lines,
all elements within that scene will be moved.
♦ Clicking the 2 button will make both slug lines and action descriptions visible. Action
description, along with its associated dialogue, can then be clicked and dragged
independently of a slug line.

Macros
Another powerful tool for customizing MS Word is the macro. A macro is in essence a small
computer program that automates a procedure. You say you’re not a programmer, no problem.
MS Word lets you record macros.

To Record Macros
♦ From the Tools menu, select Macro
♦ On the dialog box that opens, click on record
♦ If desired, choose to assign the macro to a menu or toolbar or give it a keyboard
combination
♦ Perform the procedure you would like recorded as a macro (using the keyboard and
menus, mouse actions within the document window are not recorded)
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Figure 5 Macro Record toolbar
♦ To stop recording, click on the square icon on the floating Macro Record toolbar (figure
5, the macro recording can be paused by clicking on the Pause button, to the right of the
stop button)
All of the tools and shortcuts available within Script Werx are macros, most of which include
dialog boxes, input boxes or some other functionality that requires programming in addition to
what is possible by using the Macro Recorder.

The Parenthetical Direction Tool
The Parenthetical Direction tool is a good example of this. A macro could be easily recorded to
create a new line under a character cue, apply the style for a parenthetical direction, enter a
direction, create a new line and apply the Dialogue style. However, a different macro would
have to be created for each parenthetical direction and the writer would be limited to using the
parenthetical directions for which macros were pre-recorded.
To overcome this limitation, Script Werx adds an input box. As part of the normal operation of
the Script Werx Parenthetical Direction tool, this input box opens to accept any direction that
the writer wishes to use. On clicking OK, whatever was entered becomes properly formatted
as a parenthetical direction. An option controlled in the Preferences dialog box (Figure 4) lets
the writer choose whether parenthetical directions are placed on the line below the cursor’s
current position or are always placed on the line directly below the character cue (without
moving the cursor from its current position). Similar macro-based tools make it easier to
designate dialogue as voiceover, off-camera or continuing.

Pagination with MOREs and CONTINUEDs
Another good use for macros is formatting page breaks for a shooting script with the
appropriate MOREs or CONTINUEDs. A “Formatting for Shooting Scripts” toolbar makes
these tools available.

Figure 6 Formatting for Shooting Scripts toolbar
Clicking CONT’D on this toolbar (figure 6) inserts a properly formatted CONTINUED on
either side of a page break.
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A substantially more comprehensive macro is invoked by clicking the Repag button on this
same toolbar. This starts the Repagination tool, which properly formats page breaks on
every single page throughout a shooting script. Similarly comprehensive macro-based tools are
available from this toolbar to control scene numbering and to create A-B pages (which
preserve existing page numbering by designating new pages with alpha-character suffixes e.g.
3A, 3B, 3C.).

Character Cues
The way Script Werx handles character cues (for both screenplay and video-format scripts)
exemplifies even more sophisticated macros. These macros are controlled from a special
Character toolbar. When first creating a script, these buttons are blank. The first time a button
is clicked, an Add Character Cue dialog box opens.

Figure 7 Add Character Cue dialog box
If a character name is entered and the OK button is clicked:
♦ The entire name entered appears on the toolbar button that was clicked to open the Add
Character Cue dialog box
♦ A key combination is created using the first letter of the character’s name in combination
with the indicated modifier key
♦ A warning will be displayed if the key combination conflicts with an existing key
combination
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When that same button—now labeled with the character’s name—is clicked again, a new line
will be created, the character’s name will be entered and properly formatted as a character cue
and new line will be created below that and properly formatted to begin accepting dialogue.
Pressing the key combination would have the same affect as clicking the toolbar button.
The Add Character Cue dialog box (Figure 7) provides several options. To cut down on the
size of buttons on the character toolbar, a shortened name can be entered which will then be
used as the button’s label (the full name will still be entered as a character cue). A different key
combination can be entered, using any combination of modifier keys and keyboard keys. And
the name can be added as an AutoCorrect entry, so when the writer types the chosen initials
and presses the space bar, those initials are expanded into the complete character name. This
makes it easy to use the character’s name in dialogue or action description. Adding
AutoCorrect entries without the help of this Script Werx dialog box would require finding and
opening the AutoCorrect dialog box, retyping the name and entering the initials to use.

Templates
The macros and styles mentioned so far are great for screenwriting, but irrelevant for writing
other types of documents. So wouldn’t it be nice if there was some sort of container that would
make them available while working on a screenplay then hide them at all other times. There is.
It’s called a template.
In addition to providing a container for styles and macros, templates can include cover sheets,
headers and footers, and any type of additional pro-forma material. They will even let you
create customized menus and toolbars available only when working on a document that is
attached to a specific template.
Each Script Werx template has a unique Script Werx menu and up to 3 Script Werx toolbars
that provide access to the tools and shortcuts that are of value when writing in that particular
format. The twelve templates included with Script Werx are:
♦ Screenplay Format Templates for…
•

Feature Films

•

Corporate and Informational Videos

•

Live-Tape TV Scripts

•

3-Camera TV Scripts

♦ Combination Template
♦ Two-Column Template
♦ Four-Column Template
♦ Storyboard Template
♦ Creative Treatment Template
♦ Research Questions Template
♦ On-Camera Questions Template
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♦ A behind-the-scenes template used for creating scene lists, shot lists and teleprompter
files
The Script Werx installer places all of these templates into the Templates folder used by
Microsoft Word.

To create a new script based on a Script Werx template
♦ From File menu, select New. A dialog box will open showing all templates available

Figure 8 New dialog box
♦ Double click to select a template. A new, un-named document will be created, based on
the template you selected

To create a new template
♦ Modify any Word document or template, changing styles, headers, footers, cover sheet
and/or styles
♦ From the File menu, select Save As
♦ Name the template in the box for Save Current Document As:
♦ On the scrolling list of files and folders, locate and open the folder for Templates
(within the folder for either MSOffice, Microsoft Word 6 or WinWord)
♦ On the dialog box that appears, in the lower left corner, under Save File As Type:, use
the popdown menu beneath to select Document Template
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Attaching to a Template
Any word document can be attached to any existing template
♦ With the document active on the screen, from the File menu (Tools menu in Word 97),
select Templates
♦ On the dialog box that opens, click on Attach (center top)
♦ Use the scrolling list of templates that opens to select a template
♦ Click OK in each of the dialog boxes to close them

Two-Column Video format
Script Werx uses Microsoft Word's table feature to create multi-column formats (two-column,
four-column and storyboard templates). A two-column script is simply a two-column table
with each visual description on its own row. This locks the audio with its respective visual
description, regardless of how much longer one may be than the other.
Pressing the Tab key moves you through this format: Press the Tab key when your cursor is in
the visual column to move into the audio column and press Tab again to move into the
following visual description. To add rows (new visual descriptions) simply continue pressing
the Tab key, new rows will be added at the bottom of the script.

Character Toolbar
A character toolbar is provided with the multi-column script formats as well as with the
screenplay formats. The only difference is that in the multi-column formats, character cues are
automatically placed in the upper right corner of the audio cell, regardless of where the cursor
is when a character cue tool is invoked. Even if you decide to enter a character cue after having
already begun writing the voiceover or dialogue, the character cue will be properly placed,
without disturbing what has already been written.
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Importing text
Some of the biggest time and frustration savers in the two-column template are found on the
Import Text toolbar.

Figure 9 Import Text floating toolbar
They help you quickly import and format existing text or files, which fills a common need
since this format is often used for projects that begin with client-supplied voiceover or some
other type of existing text.

To Import And Format Existing Text or Files
♦ Place your cursor in the audio column where you want to insert the text or file.
♦ Either paste in the text or Click the Import File button on the floating Import Text
toolbar. A browser dialog box will appear to let you select the file to import.
♦ After the file imports, apply shot breaks. The Shot Break tool lets you individually
place each shot break (placing each segment of text on a separate row corresponding to
its visual description). The Break All tool creates a shot break after every paragraph
(hard return).
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Shot Numbering
Script Werx provides a number of options specialized for multi-column script writing.

Figure 10 Shot Numbering dialog box
Dynamic numbers can be added that will update automatically as shots are added or deleted.
Shot numbers can then be locked in place when the script goes into production, making them a
reliable reference system. Added shots are then designated with alpha character suffixes (6A,
6B. etc.).

Line numbers
Line numbers can also be added. These line numbers can be placed between the two columns
or in the right margin.
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Lists and Storyboards
Microsoft Word makes it possible to break out elements of a script as reference documents
during production. This is done by making a copy of the script and then deleting all but the
elements of interest. A storyboard can be created by replacing the visual descriptions by picture
frames or empty frames defined by borders.
Though easy to suggest this, it requires a working knowledge of several MS Word commands
and takes several steps to complete. Using Script Werx however, several production
documents can be created with single-click ease:
♦ Shot list—creates a list of all visual descriptions from any multi-column video script
♦ Scene list—creates a list of all slug lines (scene descriptions) from any screenplayformat script
♦ Teleprompter file—creates a file of all spoken lines from either screenplay- or
video-format scripts
♦ Two/Four-Column Copy—creates a two-column version of a four-column script or
a four-column version of a two-column script
♦ Storyboard—provides several options depending on the format of the initial script,
letting you choose to have an audio column only or both audio and action columns in
addition to the column of storyboard frames

Contact Information
Script Werx is a product of Parnassus Software:
1923 Lyans Drive
La Cañada, CA 91011
(818) 952-5210

Script Werx is available for immediate purchase and download from the Original Vision web
site: http://www.originalvision.com/ or by calling
1 (800) 464-7511.
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Two-Column Example
Approved: ______
V
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FADE IN :
1. This is the paragraph
describing the first visual. To
move into the audio for this
visual, press either Tab or the
right arrow key.

NARRATOR: This is the first audio paragraph

2. A new row appears.

To move your cursor into a new row, use the

in the script.

Tab key.
3. CU: Finger pressing the Tab
key.

The best way to move among existing cells
and rows, is also by pressing the Tab key.

4. Angle on using the mouse.

Using your mouse is another way to move your
cursor around in your script.

5. Angle on dotted boxes around
the cells.

Cell boundaries are defined by these dotted
boxes you see on the computer screen, They
will not appear on the printed script.

6. Show cursor in video column.

Different styles are applied to the video and
audio columns. With your cursor in the video
column…
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Screenplay Example
EXT. LUXURIOUS MEDITERRANEAN RESORT HOTEL - MAGIC HOUR
A sumptuous lifestyle of tennis, boating and spirited thoroughbreds looks even more
magnificent as the sun nestles into distant hills.
WARREN (V.O.)
A chance meeting… a lady in need… This could be the
vacation of my life.
EXT. POOL-SIDE - CONTINUOUS
ROSALINE, a ripe 29, is giving a $5 tip to a BELLBOY who has just delivered an express
package. A new LAPTOP COMPUTER sits on the table beside her.
ROSALINE
You may have just saved my screenwriting career.
BELLBOY
(hurrying off)
Grazie.
As Rosaline rips open the envelope, we see...
SCRIPT WERX PACKAGE
...as Rosaline removes its contents. She tosses the user’s guide aside and tries to insert the
disk into her laptop backwards.
WARREN (O.C.)
The other side goes in first.
WARREN, a handsome 32, smiles down at Rosaline, as he towels himself off from a vigorous
swim.
ROSALINE
(gesturing to the laptop computer)
They said this thing is supposed to save me time.
WARREN
It depends on how you use it.
ROSALINE
And I suppose you know all about these things?
Warren slides down into the chair next to Rosaline, as he notices the Script Werx logo on the
disk.

